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Abstract
Design professionals are constantly tasked with trying to sell an idea, be it their own 

or a client’s.  Communicating and reproducing those ideas by the most efficient 

means possible is a highly sought after skill.  With the advent of SketchUp and its 

ease of use as a three dimensional modeling program, the digital designer can quickly 

take multiple perspectives of a single model and enhance them beyond their basic 

forms with the powerful rendering capabilities of Photoshop.  The ability to render a 

perspective to obtain a photorealistic quality, a watercolor appearance, or anything in 

between, makes the new digital artist a much-desired commodity.  This versatility is 

exactly what is needed in an industry that heavily relies on graphics to communicate 

ideas in an era where digital media rules. 

This guidebook includes two proven rendering techniques that use SketchUp and 

Photoshop to produce visually enhanced images.  These methods were chosen be-

cause they were the most effective techniques at producing results that were not only 

consistently successful, but easy to learn and quick to implement. These techniques 

surfaced out of at least a dozen tested and researched methods I gathered from various 

online digital rendering sites and forums, as well as several graphic design books and 

periodicals.  They are the very best. 

The techniques described within can be applied by following a step-by-step process 

that will help the reader to achieve the same consistent successful results in the same 

effective manner.  Even more importantly, they will lay a greater overall conceptual 

foundation in which the user may create their own techniques.  Ultimately, the goal 

of this guidebook is to stimulate creativity and confidence in the aspiring digital art-

ist.
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An Introduction



�

The Purpose
This guidebook presents two powerful and easy to learn digital rendering techniques for using 

the three-dimensional modeling program, SketchUp, and the graphics-editing program, Photo-

shop.  Its purpose is to guide you, the aspiring digital artist, to easily produce and enhance your 

renderings through a step-by-step process.  This guide is structured for both the seasoned and 

novice digital artist.  It will serve as a point of reference where these techniques can be explored 

for their method of creation, visual end product, and suggested application. 

These systematic methods, although quite different in their approach, introduce important gen-

eral concepts of the use of layers, filters, masks, brush types, and color adjustments that can be 

applied to most design projects in a variety of ways.  These techniques are a platform from which 

you can explore and experiment, ultimately taking your work to the next level of visual commu-

nication.

The Programs
The three-dimensional modeling program, Google SketchUp 6, has been heralded for its intu-

itiveness, flexibility, and ease of use.  Its innovation in computer-aided design opens the digital 

realm of rendering to professionals and non-professionals alike.  Though as easy and exciting as 

3D models are to make, the printed 2D end results can look generic or even “cartoony,” especial-

ly when compared to the actual sketches they are supposed to emulate.  This comes as no surprise 

because rendering is not SketchUp’s main function.  However, it does not limit creative rendering 

because of its ability to export various file types and work cooperatively with other applications.  

This allows the user to enhance their models and present their ideas in a more professional and 

effective way.

When teamed with Adobe Photoshop, the industry standard for graphics editing, truly artistic 

representations of one’s work can be created with modest knowledge of both programs and a 

little extra time.  It should be noted that these two programs were chosen because of their acces-

sibility, not only because Photoshop is an industry standard, and Google SketchUp 6 is easy to 

learn and can be downloaded for free, but because both can run on Mac and Window operating 

systems. 
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The Following Pages
In the following pages, you will find comprehensive, yet easy to follow step-by-step instructions 

to render images exported from SketchUp using Photoshop. Both methods make similar use of 

multiple layers and low opacity brushes to reveal color that lies beneath in a layered and very 

paint-like effect. One method involves exporting multiple layers from SketchUp and simply 

erasing away the top layer with calculated brushstrokes to produce a watercolor effect.  The other 

method emphasizes the use of filters, masks, and adjustment layers with less regard for brush-

strokes, but more attention to detail.  

Each technique will begin with an overview, a short list of advantages and disadvantages, and 

suggested applications if they are limited in any way.  The step-by-step instructions are written in 

a similar and easy to follow numbered format, and are supported by accompanying graphics and 

screen captures.  At the end of each technique, you will find more digitally rendered examples, 

and a few additional recommendations or tips.  At the very end of the guidebook you will find a 

glossary of commonly used terms and a list of references.  

As one last note, throughout the guidebook, I will often refer to myself as your guide, and will 

offer personal advice and observations that are based on research and experience using these 

techniques.  These may prove helpful through your trials, but are by no means necessary to reach 

a final product.  In the essence of time, you may choose to skip this information and move at a 

much quicker pace by following the numbered steps.  It is my hope that this guide will show you 

the possibilities of digital rendering and encourage you to explore and build your own tech-

niques.
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The Techniques
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The Dennis Technique

Figure A-1
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Overview
The Dennis Technique is a method of rendering that will quickly turn your basic SketchUp 

perspective into an image that resembles a watercolor image.  Here is where you will find a great 

introduction to the “painting” process that is also utilized in the Locke Technique.  The overall 

idea is to place a black and white rendering over a colored one, and then selectively erase areas of 

the black and white layer to reveal the color underneath.  This technique tends to look best when 

there is more white than colored space.  Color is used to draw the attention of your viewer’s eyes 

and accentuate the important areas of your drawing.  The creator of this technique developed it 

as a “standardized method that would help achieve a somewhat predictable ‘feel’ for presenta-

tions…A vague [and] not settled image is the philosophy.”

	 “Recipe: Put B&W rendering in Photoshop over the color one, pull out a really rough		
	   eraser - have fun.” - Dennis

Advantages
   -  Fast and Easy!  (can render in ten minutes with experience)

   -  Open for creative input and experimentation (explore different brushes how to use them)

   -  Basic understanding after two or three tries

   -  Great for simple or detailed models

Disadvantages
   -  May require a stylus for most effective use

   -  Watercolor appearance may not be readily apparent without practice

   -  May require more artistic license for perspectives with edges that meet the borders of the 		

       page and/or have large flat textureless spaces

   -  Interior shots, plan views, and close-up perspectives may be more difficult to render than an 	

       exterior perspective from afar

Suggested Applications
   -  Faraway perspectives seem to use this technique most effectively 

   -  Buildings make ideal focal points

   -  Perfect for quick renders and concept communication
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How To
Basic Setup

In SketchUp you will need to export three different images of the same perspective to import 
into Photoshop:

	    1.  Color/Texture, Shadows, and No Edges
	    2.  Edges Only
	    3.  Edges and Shadows

(Suggestion:  Your guide recommends you use flat colors rather 
than textures because they often detract from the watercolor 
look this tech is focused on reproducing.  Avoid very repetitive 
textures such as roof shingles, bricks, tiles, etc.  Experiment 
though and discover what works best for you.)

(Note:  The following step-by-step process adheres closely to the creator’s original.  Please 
refer to the Additional Recommendations section for ways to take this method even further.)

Figure A-2

Figure A-3
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Step 1. Layer 1 – Color/Texture, Shadows, and No Edges

This layer depicts the watercolor element of the rendering.

1.1  In SketchUp, to create the first layer, use white as your Ground color, and either white or 
blue (the default blue works just fine) for your Sky color.   

To change the Ground and 
Sky colors, go to Window > 
Styles.  Select Edit and apply 
your changes. 

(Point of Experimentation:  The Styles menu 
is a great place to experiment with all aspects 
of your model’s look.  For this technique 
you may want to play around with how the 
line work is portrayed.  In any case, it is 
usually wise to be consistent with what you 
choose for all your layers.)

1.2  Turn on Shadows, and turn off Edges. 

To turn Shadows on or off, go to 
View > Shadows.  To adjust shad-
ows by changing the time and date, 
go to Window > Shadows. 

Figure A-4

Figure A-6

Figure A-7

Figure A-8

Figure A-5
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To create a Scene, go to Window > Scenes.  Click 
the plus sign.  Make sure to select ‘Save as a new 
style’ before you Create Scene.  As you create more 
Scenes, you can reselect them at any time to return 
to previous settings, other perspectives, etc.

(Note:  It is inevitable a client will ask you to make some minor changes to your render-
ing such as adjusting a car’s placement or removing certain trees.  Creating Scenes as above 
will allow you to return to your model and make the changes with relative ease.  You won’t 
have to worry about finding the exact perspective or changing the settings again.  Because 
of how quick this technique can be, it is possible to do all this and the final rendering in 
front of your client’s eyes. This can be very useful and impressive.)

To turn Edges on or off, go to View > 
Edge Style and uncheck Display Edges and 
Profiles.  You can also change these in the 
Styles menu (Window > Styles).

1.3  Save these settings and your chosen perspective by creating a Scene.

Figure A-9

Figure A-10
Figure A-11
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(Suggestion:  These export settings are a good standard 
for any of the techniques.  As a rule of thumb, your 
guide never exports at a lower width than 3000 pixels 
and a lower resolution of 150.  Again, find what works 
best for you.)

(Note:  Higher resolutions typically yield thinner lines.)

To export the image, go to File > Export > 2D Graphic.  
Select JPEG as your Format type, and click Options.  
Uncheck Use View Size and apply your settings.  It is 
usually a good idea to leave Anti-alias checked. It helps 
reduce jagged edges. 

1.5  Save the file into an easy to find location with a 
name such as ‘ProjectName_Perspective1_ColorLayer.’

1.4  Now, export the image at an Image Size of 4000 pixels wide (the height will adjust accord-
ingly), and a Resolution of 300. 

Figure A-12

Figure A-13

Figure A-14

Figure A-15
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Step 2.  Layer 2 – Edges Only

This layer represents pencil work over the watercolor.

(Note:  At any time if you accidentally bump the perspective from its original position, 
click on the Scene at the top that you made.  This will restore the view.  It is essential all 
the images are exported from the exact same perspective.)

2.1  To show only line work 
(Edges), turn off Shadows (View 
> Shadows), and go to View, Face 
Style, and select Hidden Line.  
Make sure both the Ground and 
Sky colors are white by changing 
them accordingly in the Styles 
menu (Window > Styles > Edit).

Figure A-16

Figure A-17

Figure A-18
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(Point of Experimentation:  
To get more of a “pencil 
feel” to the line work, try 
using extensions, or even 
select the Sketchy Pencil 
style from the Style menu.)

2.2  Create a Scene (Window > Scenes > click plus sign > Save as new Style > Create Scene).

2.3  Export the image as above using the same settings (File > Export > 2D Graphic).

2.4  Save the file as ‘ProjectName_Perspective1_EdgesOnly’ or something similar.

Step 3.  Layer 3 – Edges and Shadows

This layer will be the top layer, which you will erase from to reveal the color beneath.

3.1  To create this layer, just turn on Shadows and Export the image.  Be sure to create a scene as 
well, and save your SketchUp file. 

(Note:  Make sure you are using the same shadow settings as you used when creating the first layer.)

Figure A-19

Figure A-20

Figure A-21

Figure A-22
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Step 4.  Importing and Overlaying Images in Photoshop

4.1  In Photoshop, Open the Color/Texture, Shadows, and No Edges file (File > Open or Ctrl/
Cmd + O).  Duplicate the layer (Ctrl/Cmd + J) and Delete the Background layer.  

4.2  Apply the Ripple filter to distort the straight edges (which would be difficult to make with 
real watercolor).  To do this, go to Filter > Distort > Ripple. (Amount: 50%, Size: Medium).  

(Point of Experimentation:  Play around with the Ripple filter settings to see what yields 
the best results.  Different settings will have varying effects on different image sizes.)

(Note:  Your guide believes this filter is only effective if you will be reproducing larger 
images.  You may have to increase the amount of Ripple for it to show in smaller images.  
You may choose to ignore this step altogether if you see fit.)

Figure A-23

Figure A-24

Figure A-25
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4.3  Now Open the Edges Only file and Select-All the entire image (Ctrl/Cmd + A).  Copy the 
image (Ctrl/Cmd + C) and Paste it into the open Color/Texture, Shadows, and No Edges file 
(Ctrl/Cmd + V).  It should paste on top of the color layer, and hide all the color.  

4.4  To blend or overlay the line work, click 
the drop down box that says ‘Normal,’ which 
resides in the Layer window just below the 
word ‘Layers.’  These are Photoshop’s Blending 
Options, which can be incredibly useful in any 
creative project. Try them out sometime.  For 
now, select Multiply.  The image should appear 
almost as it did originally in SketchUp, but 
with the colors bleeding into each other under 
the line work.

Figure A-26

Figure A-27

Figure 
A-28

Figure A-29
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4.5  Open the Edges and Shadows file, select the entire image (Ctrl/Cmd + A), Copy it (Ctrl/
Cmd + C), and Paste it (Ctrl/Cmd + V) into the other file as you did above.  This should be the 
third and topmost layer.   The color will disappear again.

(Tip:  It may be useful to rename the layers so they are more useful to you.  This will become 
exceedingly more important in other more sophisticated techniques that use more layers.)

This would be a good time to Save your work (Ctrl/Cmd + S).

Step 5.  “Painting” the Image

Here is where you will be erasing the topmost layer to reveal the color beneath.  This will actually ap-
pear as if you were ‘painting’ on the color.  This is where the real art begins.

5.1  Select the Eraser Tool (E), and choose a non-typical 
brush (typical brushes that are found and soft 
produce more of a gradient effect rather than a 
brushstroke effect, and are not recommended).  
To do this, click the drop down arrow next to the 
selected brush up at the top in the toolbar.  To 
load different brush types, click the small right-
ward pointing arrow and select what interests you.  
When it asks you if you want to replace the cur-
rent brushes with the new ones, click OK. 

(Point of Experimentation:  There is a lot of room for experimenta-
tion here so take your time and try out different brushes as choosing 
one will affect the final look of your rendering.  To return to the Basic 
Brushes, do as instructed above and select Basic Brushes.)

(Suggestion:  If you are having trouble on where to begin, try the Wet Media Brushes.  
Holding your cursor over each brush will allow you to see a short description of it.)

Figure A-30

Figure 
A-31

Figure A-32
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5.2  Set the Opacity of the brush to 50% or less (to reveal less color, make this percentage a lower 
value).  You can change this at the top in the toolbar as well.

The size of the brush should be relatively large, but will change according to the 
size and distance of the object you are painting.  Keep in mind that the larger 
the brush is, the faster you can apply this technique. 

5.3  Make sure the Edges and Shadows layer is selected and apply the eraser brush to the image.  
Try to “paint” quickly and don’t worry about imperfections.  Erase only the most important areas 
of your model to create focal points.  Ideally, the more white you leave on the page, the better 
the final rendering will look.  After the first pass, go over the image again and perhaps a few more 
times to create a layering effect of the brush strokes.  This will create an appearance as if you 
used several layers of watercolor, adding texture to the otherwise bleak surfaces SketchUp often 
produces.  Try to move the brush as you would a real brush (or use a stylus if you have access to 
one).  Where two different colors lie adjacent to each other, brush one area first before moving 
onto the other and avoid overlapping.  

(Tip:  If you used flat colors in your model, or maybe even simple textures, 
use the Magic Wand Tool (W) to select the separate color areas and then 
erase them.  This will help speed up the process and prevent overlapping of 
your brush strokes.  To Deselect, press Ctrl/Cmd + D.)

Figure A-33

Figure A-34
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And that’s all there is to it!  Find another perspective, try it again, and have fun!  Here are a few 
tips from the creator himself:

	 “Imagine that you are really painting on paper rather then erasing.”  – Dennis

	 “It is important to leave lots of imperfections. Fortunately it is easy to do - just do a fast and 	
	 sloppy job erasing with a big rough eraser.”  – Dennis

	 “What I do is give the drawing a lot of white space around and keep the color pretty much to 	
	 the center - as little color as I can get away with.”  – Dennis

	 1. Keep the trees a bit transparent (line work only)
	 2. Lighter colors and shadows because watercolors like to be light, full of air 
	 3. Kick the SU jitter out. It looks way cleaner to wiggle the line work in PS (use Filters > 		
	    Brushstrokes > Splatter on your line work and keep it smooth)
	 4. Thinner and lighter line work (higher resolution and lower opacity on line work)
								        – Dennis

Additional Recommendations
Create a Watercolor Sky Wash
To add a more interesting sky to your image, select the Color/Texture, Shadow, and No Line lay-

er and using the Magic Wand Tool (W), select the sky and delete it.  Find a sky or cloud photo 

to use and apply the Dry Brush Filter (Filter > Artistic > Dry Brush).  Copy the image and Paste 

it into your document.  Click on and drag the Sky layer underneath the Color/Texture, Shadow, 

and No Line layer.  To reveal it, erase away the sky portion of the top layer (make sure to select it 

first) and apply the above methods to your brush strokes.

Add More White Space
Because sketches often never fill an entire page, you may want to add a soft edge to your render-

ing if there isn’t already one.  Erase non-essential parts of your drawing wherever possible, espe-

cially at the edges.  You may or may not want to increase the Canvas Size (Image > Canvas Size) 

and fill in the transparent areas by creating a new layer (Shift + Ctrl/Cmd + N), filling it with 

white using the Fill Tool (G), and dragging the layer to the bottom. 



19

Fade Out Line Work
Using an eraser, fade out the line work at the edges (on the respective Line Work Only layer), 

making them darker as you approach the focal points of your image.  This will have a similar ef-

fect of placing added emphasis just as revealing the color does. 

Add Paper Texture
Try printing on textured paper to add “authenticity” to your image.  If that is too difficult, you 

can simulate a paper texture in Photoshop by going to going to Layer > New Fill Layer > Pat-

tern.  Click OK and load Artist Surfaces by clicking on the pattern swatch, and then on the small 

rightward pointing arrow.  Click OK, choose a texture, and adjust the Scale appropriately.  Click 

OK and set the Blending Mode of this Pattern layer to Soft Light (located in the upper left of the 

Layers window, defaulted at ‘Normal.’).

	 “Usually if I apply canvas I do it to the sky and white spaces only (it will look like 		
	  you had rough paper and thick paint).”  - Dennis

Speed Up the Process
Instead of exporting three different images in SketchUp, you may only want to export two by 

adding lines to the first layer (the Color/Texture and Shadows layer).  Apply the Ripple Filter as 

you see fit or not, and ignore the Multiply Blending Option step. 

Erase Non-Destructively Using Masks
You will inevitably make mistakes during the erasing process, and be unable to go “back in 

time” far enough (using the History window) to undo your error.  To avoid this problem, create 

a Reveal All Layer Mask by selecting the top layer and selecting Layer, > Layer Mask > Reveal 

All.  No changes will be apparent, but you may notice a white rectangle appear next to a smaller 

version of your image in the Layers window.  That small white rectangle represents your Mask.  

Instead of revealing the color underneath using the Eraser Tool, you will instead use the Brush 

Tool (B).  To effectively “erase” the areas as you did before, make sure black is your foreground 

color (switch by pressing ‘X’), select your brush settings as before, and have at it.  If at any time 

you make a mistake or realize an area has too much color, toggle the foreground color to white 

(X) and paint over the area.  To restore a portion of the image to its original state to start over, 

change the brush Opacity to 100% and then continue. 
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Updating the Model and Rendering Without Re-Erasing
There will be times when you want or are asked to make changes to the original model.  This will 

require you to re-export the images from SketchUp and re-import and edit them in Photoshop.  

To save yourself a considerable amount of time of having to re-erase, you can take your previous 

work’s effort and apply it to the newly updated image.  To do this, import your new layers into 

your old Photoshop file of your previously rendered image.  Select you old top layer (where you 

made all of your erasing) and go to Select > Load Selection > Ok (Channel default should be 

“Name of Layer” Transparency).  Make sure to check Invert.  Now, click on your new top layer 

and Delete.  You may or may not have to erase more depending on your changes.  To adjust the 

selection before you Delete to prevent undesired erasing, click on a selection tool from you tool-

bar and select the icon for ‘Subtract from selection.’ 

If you are using Layer Masks as instructed above, you can easily transfer your old mask to the 

new layer simply by clicking and dragging it to the new layer.

Play around with Hue/Saturation, Levels, Brightness/Contrast settings, and Blending Modes

When you are finished with your rendering, you may want to play around with the color settings 

to adjust the final outlook of your image.  This can be done in countless ways in Photoshop, the 

majority of which can be found in Image > Adjustments.  Your guide most often uses Levels, 

Brightness/Contrast, and Hue/Saturation, but encourages you to explore some of the others, 

including Variations to get creative.  

Experiment with Blending Modes as well (the drop down box is located in the upper left of the 

Layers window; default at ‘Normal’). First make one or more Duplicates of your image (Ctrl/

Cmd + J) and apply Multiply, Hard Light, Soft Light, or any of the other modes to achieve 

your desired results.  You can reduce their effect by selecting the layer of choice and adjusting its 

Opacity, which is located as a percentage in the upper right of the Layers window.  Use Multiply 

and a low Opacity setting to subtly make the colors of your image more vivid.

In any of the cases above, you may find it easier to Flatten your image (compress all the layers 

into one) and edit it independently from you base file.  To Flatten the image, click on the small 

rightward pointing arrow in the upper right of your Layers window and select Flatten Image.  It 

is suggested you Select-All (Ctrl/Cmd + A) and Copy this image (Ctrl/Cmd + C), create a new 

file (File > New > Ok), and Paste the image there (Ctrl/Cmd + V).)
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Dennis Technique Examples

Figure A-35

Figure A-36
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The Locke Technique

Figure B-1
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Overview
The Locke Technique involves manipulating the entire image through the use of filters, masks, 

and adjustments layers in addition to using the “painting” method to reveal color as introduced 

by the Dennis Technique.  The formulaic process creates results that are predictable between 

various perspectives of a single project, which can be very useful when trying to produce several 

rendered images in a timely manner.  This rendering method can be quick, but often requires a 

detailed image for it to truly shine.  Whether you apply them within SketchUp or in Photoshop, 

the use of photo textures and/or pre-rendered objects (cars, trees, people, etc.) is highly recom-

mended. 

The Locke Technique was discovered in the Advanced Photoshop magazine under the “Frog 

Princess” tutorial.  It earned its name when part of the tutorial was adapted for use with images 

exported from SketchUp.  The technique was first applied to a redevelopment and revitalization 

project for the Chinese Historic Town of Locke.  By default, the technique produces a sepia tone 

effect that worked quite well at capturing the historic character of the town.  With a few color 

adjustments, this technique can be successfully applied to other--non-historic related--projects  

without the sepia tone effect, but with all the texture still intact.

Advantages
   -  Fast! (with experience)

   -  Great results with less emphasis on artistic license

   -  No stylus needed

   -  Can be applied effectively to any perspective

Disadvantages
   -  Introduces new methods that may intimidate the casual Photoshop user

   -  Places emphasis on detailed or photo realistic models

   -  May require more post Photoshop work (color adjustments, etc.) than other techniques to 	

       achieve desired look

   -  Requires some practice to paint “blindly” (refer to Step 4)

   -  Difficult to vignette

Suggested Applications
   -  Use images with a lot of detail, textures, photo textures, etc.
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How To

Basic Setup

For best results, it is recommended you use photo textures wherever possible in your model.  
Add photographed or painted two-dimensional or three-dimensional people, trees, cars, etc.  Be 
consistent with the amount of detail that is being exhibited in your model.  Textures that cannot 
be directly applied to the model can be applied later in Photoshop with a little creativity.  Using 
photos in conjunction with your model will yield a much more detailed final painted image.

Figure B-2
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To turn Shadows 
on or off, go to 
View > Shadows.  
To adjust shadows 
by changing the 
time and date, 
go to Window > 
Shadows. To turn Edges on 

or off, go to View > 
Edge Style and un-

check Display Edges 
and Profiles.  You 

can also change these 
in the Styles menu 

(Window > Styles).

1.2  It is suggested for your first time to use white for your Ground and Sky color.  This will bet-
ter allow you to add in your own ground and sky background later in Photoshop if you desire.

To change the 
Ground and 
Sky colors, go 
to Window > 
Styles.  Select 
Edit and apply 
your changes. 

1.3  Save these settings and your chosen perspective by creating a Scene.

To create a Scene, go to Window > Scenes.  
Click the plus sign.  Make sure to select 

‘Save as a new style’ before you Create 
Scene.  As you select more perspectives 

to render, create a Scene for each so you 
can easily revisit them if you make model 

changes later on.  

(Note:  Each Scene you make has its own set of properties based on the current settings you have 
at the time of creation.  These properties not only include Camera Location and Shadow Set-
tings, but Style settings, Visible Layers, Axes Settings, Hidden Geometry, etc.)

Step 1. 	 Exporting the Image 

1.1  In SketchUp, make sure Shadows are on and Edges are off.

Figure 
B-3

Figure B-4 Figure B-5

Figure B-6

Figure B-7

Figure B-8
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1.4  Export the image at an Image Size of 4000 pixels wide (the height will adjust accordingly), 
and a suggested Resolution between 150 and 300. 

To export the image, go to File > Export > 2D 
Graphic.  Select JPEG as your Format type, and 
click Options.  Uncheck Use View Size and apply 
your settings.  It is usually a good idea to leave 
Anti-alias checked. It helps reduce jagged edges. 

1.5  Save the file into an easy to find location.

Figure B-9

Figure B-10
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Step 2.  	 Importing the Image and Applying the 			 
		  Glowing Edge Filter 

2.1  In Photoshop, Open the file (File > Open or Ctrl/Cmd + O) and Duplicate the Background 
layer three times (3 x Ctrl/Cmd + J).  Delete the Background layer. 

(Tip:  Renaming your layers can be extremely helpful.  To do this, just double-
click on the layer name in the Layer window and type in the new name.)

2.2  Select the top layer and apply the Glowing Edges filter (Filter > Stylize > Glowing Edges).  
Make these settings:  Edge Width 1, Edge Brightness 14, and Smoothness 5. 

Figure B-11

Figure B-12

(Note:  New grass and rock textures, along with a sky, were added 
in Photoshop before this technique was started.)
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(Future Suggestion:  For an image that depicts distance or depth, you may want to make two 
selections to represent your foreground and background, and use larger and smaller Edge 
Widths respectively.  To do this, generalize between close and faraway objects and use any 
of the various selection tools to select one or the other.  Save your selection, Selection > Save 
Selection, and apply the filter.  Directly afterward, Invert the selection, Select > Inverse, save 
it, and apply the filter with a new Edge Width.)

2.3  Invert the colors by going to Image > Adjustments > Invert (Ctrl/Cmd + I).

2.4  Enhance the color slightly by going to 
Image > Adjustments > Levels, and mov-
ing the middle slider to a value of 0.55.

(Note:  For closer perspectives, you may want to increase your Edge Width to 2 or 3.)

Figure B-13

Figure B-14

Figure B-15
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(Point of Experimentation:  The settings above will produce a sepia toned 
result of your image, but you may want to explore other values for differ-
ent looks.  The monochromatic tone can be changed later, as indicated in 
later steps.)

Step 3.  Utilizing Hue/Saturation and Layer Masks

3.1  Create a Hue/Saturation Adjustment 
Layer by going to Layer > New Adjustment 
Layer, Hue/Saturation.  You can rename the 
layer if you wish.  Check the Colorize tab and 
enter these values:  Hue 32, Saturation 35.

3.2  Select the second from the bottom 
layer (one of your duplicates) and drag it 
above the Glowing Edge layer and below 
the Hue/Saturation Adjustment layer.  
Using the settings above, the image will 
appear brownish or sepia in color.

Figure B-16
Figure B-17

Figure B-18

Figure B-19 Figure B-20
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3.3  Create a Hide All Layer Mask by selecting 
the top layer and selecting Layer, > Layer Mask 
> Hide All.  The image will change to look like 
a sepia version of your Glowing Edges.  

(Note:  The small black thumbnail that 
appears in the Layer window represents 
your Mask.  You will soon discover that 
painting white on this Layer Mask will 

Reveal the image it is Hiding, and black 
will Hide it again.)

3.4  Save your file (Ctrl/Cmd + S).

Figure B-21

Figure B-22

Figure B-23
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Step 4.  	 Painting the Image

4.1  Select the Brush tool (B), and choose the 
Heavy Scatter Flow brush in the Wet Media 
brushes.  To do this, click the drop down arrow 
next to the selected brush up at the top in the 
toolbar.  To load the Wet Media brush type, click 
the small rightward pointing arrow and select it.  
When it asks you if you want to replace the cur-
rent brushes with the new ones, click OK.  Select 
the Heavy Scatter Flow brush (which should be 
fourth from the top).  Hold the cursor over the 
brush to see the name of the brush.

(Point of Experimentation:  The Heavy Scatter 
Flow brush is a tried and true brush that yields 
desirable results.  However as always when select-
ing brushes, there is a lot of room for experimen-
tation.)

4.2  Set the Opacity of the brush to 50% or less to reveal the color in layers.  You can change this 
at the top in the toolbar.

The size of the brush should be relatively large, but will change accord-
ingly to the size and distance of the objects you are painting.   Keep in 
mind that the larger the brush is, the faster this technique will be. 

Figure B-24

Figure B-25

Figure B-26
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4.3  To effectively “paint” the image, make sure white is your foreground color 
(switch by pressing ‘X’), and begin making your strokes, painting one area before 
moving onto the next.  If at any time you make a mistake or realize an area has 
too much color, toggle the foreground color to black (X) and paint over the area.  
To restore a portion of the image to its original state, change the brush Opacity to 
100% and then continue.  This is the magic of using Layer Masks.

(Definition:  For a more in depth explanation of Masks, please refer to the Glossary.)

(Important Note:  Make sure the Mask is selected on that layer and not the image 
itself.  If at any time you select another layer and return to it or another with a Mask, 
click the Mask thumbnail to edit the Mask or click the image thumbnail to edit the 
image on that layer.)

As you make your brushstrokes, it won’t be readily apparent what the final image is going to look 
like.  You will see the strokes being made, but they will appear sepia in color.  The color will be 
brought out in the next step.  Continue painting and begin to layer your strokes.  You may paint 
groups of objects such as buildings or trees all at once or individually.  Overlapping your strokes 
on other areas is OK in this technique, especially if the image has a lot of details and is full of 
textures.  Like the Dennis Technique, be quick.  Imperfections are desirable.

Figure B-27

Figure B-28
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(Note:  The more you layer your brushstrokes, the darker they will appear, and more of the 
original color of the image will come through.  If you add too many brushstrokes, you will bring 
back the original SketchUp image completely.  The less you layer your brushstrokes, the more the 
sepia toned Hue/Saturation Adjustment layer will have an effect on your final image.  It will take 
a bit of trial and error, but with a little practice you’ll find your balance.)

(Tip:  For trees and other vegetation, after a general once or twice through with your 
brush, try spot clicking randomly many times to add texture.  Concentrate your 
strokes particular sides of objects to create and accentuate shadows.)

(Tip:  At any time to get a sneak peak of how your painting is coming along, skip 
ahead to the next step to see your results and then use the History window to “step 
back in time” to continue your work.  Often times, you’ll find spots you missed that 
you may need to go over.)

(Suggestion:  You may or may not want to add a white vignette around the sides of 
the image by either applying a mask or erasing later.  Like the Dennis Technique, you 
may only want to add color to the focal points of your rendering.)

Figure B-29
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Step 5.  	 Finalizing the Image

5.1  To reveal the color 
determined by the efforts of 
your painting, Duplicate the 
layer (Ctrl/Cmd + J) and drag 
it above the Hue/Saturation 
Adjustment Layer. 

Don’t forget to Save your file 
(Ctrl/Cmd + S).

If the colors are too vivid, try adjusting the Opacity of the layer to a lower percentage.  If the col-
ors aren’t vivid enough, try Duplicating the top layer and play with the Opacity settings, Blend-
ing Modes, and/or any of the various image color adjustments (Image > Adjustments).

Layer Opacity is located as a percentage in the upper right of the 
Layers window.  The Blending Modes drop down box is located in 
the upper left of the Layers window, and is ‘Normal’ by default.

(Tip:  It may be easier to just Flatten your image (compress all 
the layers into one) and edit it independently from the base file.  
To Flatten the image, click on the small rightward pointing ar-
row in the upper right of your Layers window and select Flatten 
Image.  It is suggested you Select-All (Ctrl/Cmd + A) and Copy 
this image (Ctrl/Cmd + C), create a new file (File > New > Ok), 
and Paste the image there (Ctrl/Cmd + V).)

Figure B-30 Figure B-31

Figure B-32

Figure B-33
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Figure B-34

There are many different settings within Photoshop to help you manipulate the color of the 
image, so explore them thoroughly and find what works best for you.  When you have found 
something that works, it’s yours!

You can also tweak the Saturation.  When you have finished painting on the Mask, you can easily 
boost the saturation by clicking on the thumbnail for the actual image layer (not the layer mask), 
and going to Image > Adjustments > Hue/Saturation.  Check the Preview box and then drag the 
Saturation slider to the right in order to increase the color intensity.
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Locke Technique Examples

Figure B-35

Figure B-36

Notice the use of photo textures on the buildings.  

The ground texture appears too flat in this image.
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Figure B-37

Figure B-38

These SU trees were actually pre-rendered to look like they were painted.

It’s okay to be sloppy.  Painting quickly can yield some surprising results.
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Figure B-39

Figure B-40

The building and lawn texture work nicely.

Flat and transparent trees don’t work out so nicely.

Locke Technique Examples (cont’d)
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Figure B-41

Figure B-42

This was the first attempt at using the Locke Tech without the sepia tone.  An actual photo was 
taken of the site, and the grass and rocks were implemented in PS.  The RR tracks were made in SU 
using photos of the actual track and ties.  The paving pattern was found free online. The tree was 
bought cheaply, but produced an undesirable white halo around some of the leaves.

This was the second attempt after the client asked for the bollards and native grass to be removed.  
They also wanted a more springlike feel so the image was lightened and made more “green.”  The 
halo caused by the trees were easily removed in PS using the Clone Stamp tool.  Flowers were added  
using a Special Effects brush.
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Conclusion

  

I have found the Dennis and Locke Techniques to be two of the most efficient meth-

ods of producing high-quality digital renderings.  While I invite you to replicate the 

steps presented here exactly, I also encourage you to unravel and explore them, and 

even change or diverge from them altogether.  As you become more acquainted with 

the Dennis and Locke Techniques and the supporting methods involved, you will be 

inspired to experiment further to make it your own. 

Here’s to hoping I see the (Your Name Here) Technique soon.

Happy Rendering!
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Glossary
Adjustment Layer – A special Adobe Photoshop layer that can be used to experiment with 

tonal adjustments such as levels and curves without permanently affecting underly-

ing layers. Adjustment layers have two advantages over applying tonal adjustment 

commands alone: 1. Adjustment levels are dynamic. You can modify your settings or 

remove the layer altogether at any time you wish. 2. Tonal adjustment commands can 

only be applied to a single layer. On the other hand, an adjustment layer affects all lay-

ers underneath.

Anit-Alias – Refers to the jagged edges often seen in digital images.  It counter them by inter-

preting adjacent pixels and smoothing them by balancing their difference in color.

Blend Modes – When you create a layer in Photoshop, blend modes determine how it interacts 

with layers that are beneath it. If you change the blend mode, the layer now reacts 

with what’s beneath it (rather than just covering it) and can “blend” into it using a 

variety of colors, screens, etc. 

Brushstroke – The mark left by a loaded (filled) brush on a surface. Brushstrokes can be distin-

guished by their direction, thickness, TEXTURE, and quality. Some artists purpose-

fully obscure individual brushstrokes to achieve a smooth surface. Other artists make 

their brushstrokes obvious to reveal the process of painting or to express movement or 

emotion.

Colorize – Add color to.

Contrast – The degree of difference between light and dark areas in an image.

Design – Both the process and the result of structuring the elements of visual form.

Digital Artist - A new generation of artists that has emerged with the advent of readily available 

computer technology, which uses computer graphics software, digital photography 

technology, and computer assisted painting to create innovative art.

Export – To send data in digital format from one application to another.

Filter – A plug-in for an image-editing program such as Photoshop, which is designed to pro-

duce a certain effect. For example, filters may be designed to blur or sharpen an image, 

or to create special effects such as motion trails or fractal patterns.
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Forum – An online discussion group, where participants with common interests can exchange 

open messages.

Graphics – Includes pictographs, typography and some types of text, as well as symbols, photo-

graphs and geometric designs. Graphics are visual elements used to point readers and 

viewers to particular information.

Guidebook – a book that provides essential information to travelers and migrants about an 

unfamiliar place.

Hue –  In color, the main attribute of a color which distinguishes it from other colors.

Import – To receive data in digital format from one application to another.

Levels – An image adjustment setting that allows you to changes the value of the base colors 

(either RGB or CMYK) individually or altogether by three sliders representing low, 

mid, and high tones.

Masks – Masks in image editing software are a way of protecting specific areas of your image, 

just as you would use masking tape when painting your house. A mask consists of a 

grayscale channel, called an alpha channel and is often displayed as a ruby overlay so 

the underlying image can be seen through the mask. The darkest areas of a mask are 

the areas most protected and the white areas are unprotected. Shades of gray represent 

areas of partial protection that corresponds with the level of gray.

Model – A computer simulation of a three-dimensional object, real or fabricated.

Multiply – Multiply looks at the color information in each channel and multiplies the base 

color by the blend color.  The result color is always a darker color.  Multiplying any 

color with black produces black.  Multiplying any color with white leaves the color 

unchanged.  When you’re painting with a color other than black or white, successive 

strokes with a painting tool produce progressively darker colors.  The effect is similar 

to drawing on the image with multiple marking pens.

Opacity – Term used to describe the degree to which a layer will show through.

Perspective – A method for representing three-dimensional objects on a two-dimensional sur-

face. The process of viewing something from a distinct vantage point. 
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Photoshop (PS) – An industry standard software program by Adobe for image-editing and 

graphics creation.

Plug-in – A written program that is integrated into another application, often providing ad-

ditional functionality not available in the application.

Rendering – The process of turning a 3D scene into a 2D image that can be viewed on screen 

or printed on paper. May involve visual enhancement through such programs as Pho-

toshop.

Saturation – Saturation refers to the intensity of a specific hue. It is based on the color’s purity; 

a highly saturated hue has a vivid, intense color, while a less saturated hue appears 

more muted and grey. With no saturation at all, the hue becomes a shade of grey.

Script – A set of instructions that performs a specific function, often simplifying and/or reduc-

ing the number of tasks required by the user to attain a certain goal. SketchUp sup-

ports the use of scripts.

Sepia – The (brownish) mono toned effect seen in images from the original 19th and early 20th 

Century cameras.

SketchUp (SU)– A 3D modeling program that has been heralded for its flexibility, intuitive na-

ture, and ease of use. Its innovation in computer-aided design opens the digital realm 

of rendering to non-professionals and professionals alike with its significantly lower 

learning curve compared to those of other 3D modeling programs. Recently pur-

chased by Google and with a free version offered to the public, SketchUp is becoming 

a major competitor in the world of computer-aided design and concept creation.

Stylus – A pen-like device used to “draw” on the surface of a graphics tablet.

Tech – Slang. Short for Technique: hey, let’s do the Den Tech for our project today!

Technique – A method or way of working with materials to create a work of art.

Texture – The visual and tactile quality of the surface of an object.

Vignette – An image whose edge fades off softly into the background.

Watercolor - A water-based paint that is a translucent wash of pigment.
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